網路設備記錄

Unifi 無線設備

這個企業平民級的CP還不錯的無線AP設備

Unifi 無線設備

UniFi Controller 中控安裝流程

          BUBU 因為之前公司的無線網路一直不穩定,所以上網查詢看到有很多網友推薦 Unifi 這個品牌無線設備cp很高價格也網路上其他網路分享器的價格差不多,也等於是個企業級的設備,所以就買了這個品牌來使用,連 BUBU 自己家裡也有使用這個ap使用,用到現在穩定度還不錯,讓我也想要把全家的無線網路設備換成這個來做使用。

         但使用這個ap有一個問題就是需要有一台設備安裝中控軟體操作各ap的設定,官方有各系統的跨本中控可以使用,BUBU我是使用 linux 的版本來使用,系統版本是 Debian 9 來架設。

 

第一步:先將 Debian 9 系統更新到最新版

apt update

第二步:開始安裝 Unifi Controller 中控

         1. 安裝的方式都是安裝官方文件教學所安裝出來的 Unifi Controller 

使用以下命令添加新的源列表

echo 'deb http://www.ubnt.com/downloads/unifi/debian stable ubiquiti' | sudo tee /etc/apt/sources.list.d/100-ubnt-unifi.list

         2.添加GPG密鑰

sudo wget -O /etc/apt/trusted.gpg.d/unifi-repo.gpg https://dl.ubnt.com/unifi/unifi-repo.gpg 

        3.在更新一次系統更新包 

apt update

        4.然後開始安裝 Unifi Controller 套件

apt install unifi

安裝完之後就可以在瀏灠器輸入該設備 https://ip:8443 就可以開始連線設定服務。

 

參考相關網頁:

Unifi 無線設備

Unifi AP 跨網段指向 AC 中控

         BUBU 目前所待的公司是有三個廠區,AC 中控只有一台想要控制其他廠區的 Unifi AP 來使用,因此有在網路上找到官方所提供的文件。

         將該設備接上網路的之,進到分享器或路由器裡面查看目前該設備所取得 IP 是多少,然後再利用 SSH 方式來進到該設備進行設定。

        Unifi AP 設備默認的帳密是 ubnt

# set-inform http://xxx.xxx.xxx.xxx:8080/inform  #將 IP 改成 AC 中控 IP 

      再進到 AC 中控裡面就可以看到該廠區的無線AP設備

 

參考相關網頁:

Unifi 無線設備

UniFi Controller 中控更新

這一篇是要教學怎麼利用命令列來更新 Unifi Controller 

# wget https://dl.ubnt.com/unifi/更新版號/unifi_sysvinit_all.deb
# dpkg -i unifi_sysvinit_all.deb
# rm unifi_sysvinit_all.deb
# service unifi restart

 

 

參考相關網頁:

Fortinet FortiGate 設定相關記錄

Fortinet FortiGate 設定相關記錄

Fortinet 重置命令

如何用 Fortiner 內建的命令列,下指令還原原廠預設值。

FGT_xxxx # execute factoryreset

This operation will reset the system to factory default!
Do you want to continue? (y/n)y

按完之後設備會自動去重置並且重新開機,之後再瀏灠器上輸入 http://原廠預設IP 就可以開始使用了。
Fortinet FortiGate 設定相關記錄

FortiGate Site to Site syslog 日誌傳送

BUBU 最近在研究 Graylog 怎麼設定分析和一些功能,結果發現到從建立好到現在的 FortiGate 其他分廠都沒有傳送資料回來,去查看設定都是正常的,但是發現到如果用 FortiGate 指令去 Ping 日誌主機都沒有反應,查看 google 原因是因為要先設定是從那裡來才能正常 Ping 對方的位置,所以在建置 Site to Site 模式想要把 FortiGate 上的記錄檔傳送到其他地區的主機要先設定來源就可以正常傳送了

運行環境


FortiGate 6.0 、 5.4 、 5.6

設定過程過程


先設定 ping 來源,來源是指 FortiGate 本身
exe ping-options source 192.168.1.1

ping 目標
exe ping 192.168.20.43
先進到 syslog 設定下
config log syslogd setting

再顯示目前設定狀況
show

顯示當下狀況
config log syslogd setting
    set status enable
    set server "192.168.20.43"
end

再下面兩行指令,source-ip 是指 FortiGate 本身的 IP
set facility syslog
set source-ip "192.168.1.1"
end

那如果要修改 port 一樣是在指令列下,通常系統預設都是 514 看日誌主機 port 是多再來對應
set port 514



參考相關網頁


MikroTik RouterOS 路由器

記錄該路由器的設計及操作

MikroTik RouterOS 路由器

MikroTik RB4011iGS+ 入門設定

由於 BUBU 家中網速從 100M 升速到 300M 由於 FortiGate 60D 無支援 300M 的PPPOE 模式,因此更換這台設備使用,設定還滿簡單的,網路上也有許多文章可以參考, BUBU 是在露天上的  MikroTik專業賣家 此賣家買的,服務不錯會教怎麼設定,收到設備時賣家是有將設備改中文並且有範例可以參考及使用方式。

首先使用網頁方式登入是精靈設定的畫面

輸入 PPPoe USER 指中華電信的帳號及密碼

MikroTik-1.png

IP Address 是指以後要連到此設備的 IP 可以用預設的也可以自己定義

DHCP Server 要打勾

DHCP SERVER Range 是指 DHCP 分配的 IP 範圍

NAT 要打勾

MikroTik-2.png

這樣子就設定完成了,接下來只要按設完成就可以對外連網了可以開始享受 300M 網速的感覺的

 

 

 

MikroTik RouterOS 路由器

RouterOS 架設的服務對外公開

選項 IP -> Firewall -> NAT

Chain:dstnat
Protocol:tcp
Dst.Port:輸外對外開放的Port號

RouterOS-1.png

選擇 Extra 
Dst. Address Type -> Address Type:選擇 local

RouterOS-2.png

選擇 Action
Action:選擇 dst-nat 

RouterOS-3.png

To Addresses:輸入對外開放服務的內網設備 IP
To Ports:輸入對外開放的 Port 

 RouterOS-4.png

MikroTik RouterOS 路由器

RouterOS Port 轉送

選項 IP -> Firewall -> Filter Rules

Chain:選擇 forward
Protocol:選擇 tcp

Dst. Port:輸所要轉送的 Port
In. Interface:選擇 pppoe-out1

RouterOS-5.png

選項 Action

Action:選擇 accept

RouterOS-7.png

MikroTik RouterOS 路由器

RouterOS IPv6 設定

因為現在有些比較大型的網頁都已經開始有支援到 IPv6 服務,使用 IPv6 服務可以讓連到該網頁會比較 IPv4 還要快一些。因之前有跟中華電信申請 IPv6 的服務,一直都設定不起來,現在想到又想要把設起,也看了不少文章這一次終於成功了,因此趁現在記錄起來。

先將檢查 RouterOS IPv6 套件是否有安裝,如果有預設是沒有啟動,所以要手動先啟用 IPv6 服務

再來就會看到選項裡面多出 IPv6 選項,選擇 DHCP Client 

ros-1.png

新增加一個設定檔

Interface:選擇 pppoe-out1 由於我是使用中華電信的 pppoe 的服務

Request:要勾選 prefix

Pool Name:這個可以自行命名,等一下會用到

填入完之後按下 ok 就可以了

ros-2.png

選擇 IPv6 裡的 Addresses

ros-8.png

新增加一個設定

Address:填入 ::1/64

From Pool:選擇剛剛您所命名的名稱

Interface:這個選擇內網的 Bridge 或者 那一個 LAN Prot ,這個要選擇不然會失敗

選擇完之後按 OK ,然後你會在剛剛新增的設定檔會看到 ::1/64 會變成 IPv6 的樣子

ros-3.png

在 DHCPv6 Client 的 Ststus 下可以看到目前跟 Hinet 取的 IPv6 的位置

ros-4.png

IPv6 選擇 ND 

ros-5.png

新增加一個 ND

Interface:這個要選擇是要給誰用例如 LAN1 之類的

選擇完之後按下 OK

ros-6.png

設定 DNS 一組中華電信的 DNS 、一組 Google 的 DNS 

ros-7.png

以上設定完之後,可以去看網路卡上面的設定是否有正確取的 IPv6 的 IP

設定一下 IPv6 防火牆的設定

說明設定的內容:

一步一步逐條解說

  1. 對於輸入ROS不合法的連線會直接DROP
  2. 輸入下面CLIENT不合法的連線會直接DROP
  3. 允許對ROS合理流量的PING6(注意,V6是走ICMP V6)
  4. 允許對CLIENT合理流量的PING6
  5. DHCPv6 Client連線用的port,這是很重要的,必須要讓外面的DHCPv6Server能夠與你的ROS溝通,注意是走UDP 546 PORT
  6. 允許CLIENT建立的連線
  7. 允許CLIENT相關的連線
  8. 允許ROS本身對外的連線
  9. 除此之外對ROS的連線全部DROP
  10. 除此之外對CLIENT的連線全部DROP<這一條小弟在做 IPv6 網路測試會失敗,所這一條最好是停用別啟用。>

 

最後一條有mangle的部分是因為PPPOE撥號出去的封包大小可能加上PPP HEADER會超過1500BYTE,因此必須要處理縮小,這邊就由系統自行判斷縮小的程度(clamp-to-pmtu)

/ipv6 firewall filter
add action=drop chain=input comment="Drop invalid" connection-state=invalid
add action=drop chain=forward comment="Drop invalid" connection-state=invalid
add chain=input comment="Allow limited pings" limit=50/5s,2 protocol=icmpv6
add chain=forward comment="Allow limited pings" limit=50/5s,2 protocol=icmpv6
add chain=input comment="DHCPv6 client" dst-port=546 protocol=udp
add chain=forward comment=Established connection-state=established
add chain=forward comment=Related connection-state=related
add chain=output comment="Accept output"
add action=drop chain=input comment="Drop the rest"
add action=drop chain=forward comment="Drop the rest"

/ipv6 firewall mangle
add action=change-mss chain=forward new-mss=clamp-to-pmtu passthrough=no protocol=tcp tcp-flags=syn

 

參考相關網:

 

HP ProCurve J9280A Switch 2510G-48 韌體更新

因 BUBU 公司有採買這一台交換器,由於此交換器上的韌體比較老舊,也有許多的 bug 導至在操作上都會有一些問題,因此原廠建議我們採此韌體更新到官方新版本問題就可以決解了。

先去網路上或者 BUBU 附件裡下載  tftpd 軟體,來當伺服器上傳韌體用,設定方式如下:

tftpd.png

Current Directory 指向你所放的韌體目錄下,會建議在經過的目錄不要有中文的目錄夾不然會有問題的。

Server interfaces 選擇本機的現在的 IP 位子,如果有開啟防火牆的話會建議先暫時性關閉,這樣子交換器在尋找會比較快。

 

再來就是去 HP 官方下載該設備的最新版本的韌體,並且放置 tftpd 所指向的目錄下。使用 console 線或者 ssh 方式進入設定。

選擇 Download OS

HP-2.png

輸入 TFTP Server 的 IP 位置,就是你所放置的主機,輸入剛剛下載好的韌體檔,例如: Y_11_52.swi 輸入完之後選擇 eXecute 接下來交換器就會自動去下載韌體回來並且更新重啟設,這樣子就更新好了。