LibreNMS python 更新到 3.6版

最近 BUBU 看到官方已有發出公告說,官方已放棄 php7.1 及 python 2 版本支援,從 1.64 版起需要的版次 php 7.2 及 python 3 ,如果您目前所在的服務這兩個套件版本是底於剛剛說明的版本,請盡快更新如果未來更新或者新安裝的版本都是必需比剛剛公告的版本要高。

運行環境


本工作室環境都是在 「Proxmox VE 」 虛擬系統上架設,都是以 「 LXC 」模式為主,除非有特殊狀況會告知使用 「 VM 」 模式

  • 系統環境: CentOS 7

安裝或測試過程


請先進到 LibreNMS 目錄下,cd /opt/librenms

  • 安裝 phthon 3
yum install python36 python36-pip
  • 再來用 pip 3 來安裝一些服務
pip3 install -r requirements.txt

只要下以上剛剛說的指令就可以了




參考相關網頁